Troubleshooting the Selection of the Range of Regions and Devices


This article is intended to help you identify and solve issues that occur when filtering regions in Dashboard of EnOS Data Quality and filtering device ranges in Report.

Unable to Select the Correct Region and the Device Range


  • The correct region and site cannot be selected in the region filter in Dashboard, or the error message system internal error appears on the page.
  • In the device range filter in Report , the correct region, site, or device cannot be selected, or the error message system internal error appears on the page.

Cause


These issues may occur for the following reasons:

  • Reason 1: An incorrect organization structure was created in Admin Console of EnOS Application Portal or was assigned to users and roles.
  • Reason 2: In EnOS Management Console, Data Quality shortcut was created based on the native Data Quality application, but only the menu group and organization structure of Data Quality shortcut are assigned to users and roles in EnOS Application Portal.

Solution


  • Solution for Reason 1: Create an organization structure with 2 layers and assign assets to the lower nodes in the organization structure.
  • Solution for Reason 2: Assign menu groups and organization structures of the native Data Quality application and the Data Quality shortcut to users and roles in EnOS Application Portal.